[IronPython] [Fwd: Intermittent Bug: Loading a py file crashes winforms]

Mat Steeples mat at matssoftware.co.uk
Mon Apr 3 03:18:57 PDT 2006


---------------------------- Original Message ----------------------------
Subject: Intermittent Bug: Loading a py file crashes winforms
From:    "Mat Steeples" <mat at matssoftware.co.uk>
Date:    Mon, April 3, 2006 10:59 am
To:      users at lists.ironpython.com
--------------------------------------------------------------------------

Hi

Sorry to keep posting new bugs like this. This one's quite a weird one.
I've written a small .py file (attached) that when loading has some
strange errors.

If I type the code in by hand, then it runs no problems. If i drag the
file over IronPythonConsole.exe, then it brings up the "Submit an error
report" message. If i double click the file (so it loads with
IronPythonConsole.exe) it runs fine (although the console window doesn't
disappear when the form closes), and if I open IronPythonConsole and
import the file, it prints out the following.

1
2
3
Traceback (most recent call last):
  File H:\IronPython-1.0-Beta5\sample.py, line 6, in Initialize
AttributeError: 'Form' object has no attribute 'ShowDialog'

Hope that's enough detail. The winforms.py file that I'm using is the one
in the templates directory, but I've copied it to the lib directory.

Regards,
Mat Steeples

---------------------

And now with the attached file! :)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: sample.py
Type: application/octet-stream
Size: 79 bytes
Desc: not available
Url : /pipermail/users-ironpython.com/attachments/20060403/777b96cf/sample.obj


More information about the users mailing list