[IronPython] Loading XAML files

Gutfreund, Yechezkal ygutfreund at draper.com
Mon Jan 15 07:02:46 PST 2007


Yes, I mentioned in my first message that removing x:Class made it work.
The problem is that every time I use Blend, or test the program in Blend
or VS-Studio, blend will put it back in, and besides, VS-Studio and
Blend both need it for default code-behinds.
 
It is a pain to have to keep two parallel copies by hand. 
 
I can't see why the .LoadXAML() is does not do the same scheme checks
that are begin done by Blend and VS-studio. That is why I am writing
this list.
 
Should I call it a bug?
 
 

________________________________

From: users-bounces at lists.ironpython.com
[mailto:users-bounces at lists.ironpython.com] On Behalf Of Haibo Luo
Sent: Friday, January 12, 2007 1:37 PM
To: Discussion of IronPython
Subject: Re: [IronPython] Loading XAML files



I know little about WPF. I found
http://msdn2.microsoft.com/en-us/library/ms752309.aspx talking about
x:Class attribute. 

 

Removing x:class line, I am able to load the UserControl.

 

From: users-bounces at lists.ironpython.com
[mailto:users-bounces at lists.ironpython.com] On Behalf Of Gutfreund,
Yechezkal
Sent: Friday, January 12, 2007 5:22 AM
To: Discussion of IronPython
Cc: Vlad Vinogradsky
Subject: Re: [IronPython] Loading XAML files

 

All of that XAML code is generated by BLEND. Both Blend and VS-Studio
understand that x:Class is a member of the namespace. But I am also not
a WPF .NET guru. What I suspect is that when I use ipy, I am not using
the same libraries that do XML and XAML loading as when I use Blend and
VS-Studio.

 

Ideas?

 

________________________________

From: users-bounces at lists.ironpython.com
[mailto:users-bounces at lists.ironpython.com] On Behalf Of J. Merrill
Sent: Thursday, January 11, 2007 10:10 PM
To: Discussion of IronPython
Subject: Re: [IronPython] Loading XAML files

At 05:05 PM 1/11/2007, Gutfreund, Yechezkal wrote (in part)




I am using Blend to create XAML files and testing out the design there.
Then but all my code is done via Python using the Tutorials "avalon.py"
module.
 
It works fine. Except for one annoying glitch.
 
But for some reason the LoadXAML() call chokes on this:
 
 

>>> w.Content = LoadXaml("WebWrapper.xaml")

'Class' attribute does not exist in XML namespace '
http://schemas.microsoft.com/winfx/2006/xaml
<http://schemas.microsoft.com/winfx/2006/xaml> ' namespace. Line '6'
Position '2'.


I know almost nothing about XAML, but that error seems to be coming not
from anything related to IronPython but rather from some .Net XML
parser.  Have you attempted to confirm the validity of the file by
loading using any other development tool?

An XML validation tool should be able to determine the accuracy of the
statement that there's no "Class" attribute in that namespace.

(Is it possible that the attribute name is "class" not "Class" ?) 

J. Merrill / Analytical Software Corp 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ironpython.com/pipermail/users-ironpython.com/attachments/20070115/0ac0618c/attachment.html 


More information about the users mailing list