[IronPython] IronPython 2.0 Minimum Requirements

Dino Viehland dinov at exchange.microsoft.com
Wed Jun 18 14:42:42 PDT 2008


As everyone's probably aware Beta 3 was the first release to officially start requiring .NET 3.5 to compile IronPython and the DLR sources.  I just wanted to let everyone know that we've also now formalized what the minimum runtime requirements for IronPython 2.0 will be.  The short of this is that IronPython (and the DLR) will start requiring .NET 2.0 SP1.  The first IronPython release that will require this will be Beta 4 but it'll start showing up in our source tree sometime next week.

The reason for this change is that .NET 2.0 has a few bugs which we've been working around until this point.  There's one in particular, referencing generic fields on a type from dynamic methods, which effects our public surface, performance, and compatibility with .NET 3.5 (w.r.t. LINQ Expression trees).  As the DLR team continues their work this has become more and more problematic and we're now at the point where they need to be able to move forward.

.NET 2.0 SP1 was released last November so we hope that this gives plenty of time between it's release and the final IronPython release to enable most users to upgrade.  Also anyone who has deployed .NET 3.5 will also have .NET 2.0 SP1 installed so we're hoping this isn't too high of a bar.

If you have any questions or concerns please let us know. Thanks!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ironpython.com/pipermail/users-ironpython.com/attachments/20080618/c59d41a2/attachment.htm>


More information about the Users mailing list