[IronPython] Is there an equiv for -X:Python25 in Silverlight?

Dan Eloff dan.eloff at gmail.com
Mon Jun 23 16:40:18 PDT 2008


On Mon, Jun 23, 2008 at 6:34 PM, Dino Viehland
<dinov at exchange.microsoft.com> wrote:
> For Silverlight there's no need to pass -X:Python25 because IronPython 2.0 is 2.5 compatible by default.  What you will need to do is make sure there's a __future__.py that includes with_statement = True (or any other value) that can be imported by your Silverlight app.  Unfortunately from __future__ import [whatever] isn't so magical that it skips the import.

Aha. I checked up on the __future__ module I was using, and for some
reason it was from an older python, I copied the python25 one over and
it works just great. Thanks.

-Dan


More information about the Users mailing list