[IronPython] IronPython 2.6 final: Debugging not working?

Dino Viehland dinov at microsoft.com
Sat Dec 12 17:22:28 PST 2009


There were no changes between RC3 & the final version - the files are
all exactly the same, just now at a new link.  I just ran fc.exe on
both the MSI and the ZIP as downloaded from CodePlex to make sure 
and they're identical.

When you say "re-installed 2.6" do you mean "re-installed 2.6RC3"?  And
that fixed the problem?  What happens if you try installing 2.6 final
again? :)

> -----Original Message-----
> From: users-bounces at lists.ironpython.com [mailto:users-
> bounces at lists.ironpython.com] On Behalf Of Joshua Kramer
> Sent: Saturday, December 12, 2009 1:31 PM
> To: users at lists.ironpython.com
> Subject: [IronPython] IronPython 2.6 final: Debugging not working?
> 
> 
> Hello,
> 
> First - thanks for all the hard work going into 2.6!
> 
> But something appears to have broken between 2.6rc3 and 2.6 final.  In
> Eclipse, using either CPython 2.6.4 or IronPython 2.6rc3, I can debug a
> simple program.  Basically, with a series of 'print' statements I can
> set
> a breakpoint on one in the middle and the program will stop on the
> breakpoint.
> 
> With 2.6 final, the program does not stop on the breakpoints.  I have
> tried setting the Debug perspective manually, and removing the option
> '-X:noframes'.  At first I simply updated 2.6rc3 to 2.6, but after
> seeing
> this I completely un-installed 2.6 and re-installed 2.6.
> 
> Any ideas which bit flipped between 2.6rc3 and 2.6 final?
> 
> Thanks,
> -JK
> 
> _______________________________________________
> Users mailing list
> Users at lists.ironpython.com
> http://lists.ironpython.com/listinfo.cgi/users-ironpython.com


More information about the Users mailing list