[IronPython] IronPython 2.6 final and net 4

Dino Viehland dinov at microsoft.com
Mon Dec 14 11:00:16 PST 2009


Yes - we've got previews of this already in the form of our IronPython 2.6 CTP for .NET 4.0 Beta 2 (and previously beta 1 release).  We are continuing to update 2.6 for better .NET 4.0 compatbility and the plan is to ship a 2.6.x release in both .NET 2.0 and .NET 4.0 flavors around when .NET 4.0 ships.

From: users-bounces at lists.ironpython.com [mailto:users-bounces at lists.ironpython.com] On Behalf Of Keith J. Farmer
Sent: Monday, December 14, 2009 10:45 AM
To: Discussion of IronPython; Discussion of IronPython
Subject: Re: [IronPython] IronPython 2.6 final and net 4

Is a refresh planned for .NET 4 RTM that won't require the 2.x CLR be installed?

________________________________
From: users-bounces at lists.ironpython.com on behalf of Dino Viehland
Sent: Mon 12/14/2009 9:57 AM
To: Discussion of IronPython
Subject: Re: [IronPython] IronPython 2.6 final and net 4
Do you have .NET 2.0 installed as well as .NET 4.0?  .NET 2.0 and .NET 4.0 are side by side releases.  While IronPython built for .NET 2.0 would probably run fine on .NET 4.0 we haven't done any testing to make sure that's the case.  Additionally it would cause a lot of confusion because we have been putting out .NET 4.0 compatible releases which use new functionality that we usually ship as part of IronPython (Microsoft.Scripting.Core - the portions of the DLR shipping in .NET 4.0). Therefore lots of people would probably try and use C#/VB.NET's new dynamic support to talk to IronPython and it would fail but it wouldn't be entirely obvious why it's not working.

You should just be able to install .NET 2.0 SP1 in addition to 4.0 and things should work.

.NET 4.0 is certainly a later version and that's why the message explicitly calls out that .NET 4.0 isn't supported :)  It means later in the 2.0/3.0/3.5 series of runtimes which are all in place upgrades.

From: users-bounces at lists.ironpython.com [mailto:users-bounces at lists.ironpython.com] On Behalf Of David Waller
Sent: Monday, December 14, 2009 9:47 AM
To: users at lists.ironpython.com
Subject: [IronPython] IronPython 2.6 final and net 4

Hello,
I have been using earlier versions of IronPython 2.6 (not sure exactly which version) without any major issues. I have recently tried to install the latest 2.6 final and it complains about "requires .NET Framework 2.0 SP1 or later. NET 4.0 is not supported". I have installed .NET 4.0 as part of the Visual express 2010 software. Is there any way I can convince IronPython to update itself without uninstalling the visual express software.
Also isn't .NET 4.0 a later version of .NET 2.0

Thanks
David Waller

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ironpython.com/pipermail/users-ironpython.com/attachments/20091214/956ff602/attachment-0001.htm>


More information about the Users mailing list