[IronPython] 'Python' does not exist in current context

Justin Regele jregele23 at gmail.com
Tue May 26 13:47:01 PDT 2009


Trying to embed IPy in C#, and after digging all over the web and the
archives of this list, I can't figure out why the Python object won't load.
Here is the basic line where it goes wrong:

ScriptEngine eng = Python.CreateEngine();

All the other typical Objects are loading fine, just not the Python object.

I've tried a handful of different assemblies, and still nothing works. The
embedding example from Iron Python in Action DOES work though, and I added
assembly reflection code and can see that those assemblies were locale to
that solutions folder.

EZ quick fix, I thought was to copy those older assemblies over into the
Iron Python assemblies (after backing them up). But still no luck.

Pretty new to .NET and Visual Studio, but been dealing with CPython for
years. Anyone have any ideas on what I could be doing wrong? Running Vis
Studio 2008, Iron Python Studio Integrated, .NET 3.5
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ironpython.com/pipermail/users-ironpython.com/attachments/20090526/7a35eb1b/attachment.htm>


More information about the Users mailing list