[IronPython] Help - Running IPY with .NET 3.5

Dave Fugate dfugate at microsoft.com
Wed Nov 11 09:31:13 PST 2009


Creating a file named ipy.exe.config alongside ipy.exe that looks similar to:
<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <startup>
    <requiredRuntime version="v2.0.50727" safemode="true" />
  </startup>
</configuration>

will force IronPython to run against the given CLR runtime.

Dave

From: users-bounces at lists.ironpython.com [mailto:users-bounces at lists.ironpython.com] On Behalf Of Brian Ushman (TT)
Sent: Wednesday, November 11, 2009 7:59 AM
To: users at lists.ironpython.com
Subject: [IronPython] Help - Running IPY with .NET 3.5

Hello to All,

I am new to Python in general, but I have downloaded the latest release of IronPython.  I am using Windows XP SP3 x64.  Everytime I start IPY is says that it is using .NET 2.0, however I would like it to load with .NET 3.5.  >From what I have read on the latest release of IPY, this should be possible but I have been unsuccessful.  Is there a way to force IPY to load with .NET 3.5?

Thank you!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ironpython.com/pipermail/users-ironpython.com/attachments/20091111/5b555b2a/attachment-0001.htm>


More information about the Users mailing list