[IronPython] Unittest Module Unavailable in V2.7a1

Jones, Larry Larry.Jones at aspentech.com
Mon Aug 30 06:38:32 PDT 2010


My team is currently using VS2010 for work. I want to demonstrate that
using IronPython as our "unit testing language" can be more productive
than using either NUnit or Microsoft Test.

 

In order to integrate with VS2010, I believe I must use IronPython
2.7a1. I believe this is the only release that includes the IronPython
Tools. However, IronPython 2.7a1 fails when executing 'import unittest'.
I've submitted a work item, 28709, to the IronPython issue tracker;
however, I'm wondering if another work around exists then writing code
in 2.6.1 - which will execute outside VS2010 - but cannot be executed
from within Visual Studio (it invoke IronPython 2.7a1).

 

Thanks.

 

Have a great day!

 





This e-mail and any attachments are intended only for use by the
addressee(s) named herein and may contain legally privileged and/or
confidential information. If you are not the intended recipient of
this e-mail, you are hereby notified any dissemination,
distribution or copying of this email, and any attachments thereto,
is strictly prohibited. If you receive this email in error please
immediately notify the sender and permanently delete the original
copy and any copy of any e-mail, and any printout thereof.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ironpython.com/pipermail/users-ironpython.com/attachments/20100830/4b822cd6/attachment.htm>


More information about the Users mailing list