[IronPython] No module named wpf - VS2010

Dave Wald davew252 at tx.rr.com
Sat Apr 2 11:58:29 PDT 2011


Hi Chris,
See what happens if you just set the Interpreter Path explicitly in the 
project properties page.
That's all I've been doing.
In Solution Explorer, right click the project file and select 
"Properties" to open the properties page.
Set the "Interpreter Path" field to the actual path of your ipy.exe or 
ipyw.exe.
E.g., mine is set to  "c:/IronPython 2.7/ipy.exe", without quotes.  (I 
don't like using "Program Files..." folders - ACL issues.)

Also, it sounds you are still using the "old" tools. (Not that it 
matters in this case, but if you have haven't switched to the "new" 
tools yet, I highly recommend it.)
http://pytools.codeplex.com/
Caveat: You WILL have to uninstall IronPython 2.7 and re-install it 
WITHOUT the bundled tools, and THEN install the new tools. They cannot 
be installed sxs. But I think the effort is well worth it.
And there is a really good walkthrough for it.
(In the new tools, you also have Tools>Options>Python Tools with several 
settings tabs for more options.)

I just finished converting my IPyScratchPad app (gen-purpose utility UI) 
to WPF from WinForms and switched to the new tools mid-stream, just for 
extra fun.
But I've had no trouble with it.

BTW, did I mention the new tools ARE GREAT!. Thanks, y'all.

Dave

On 4/2/2011 12:20 PM, Chris wrote:
> Hi all,
>
> I get this Exception when trying to run a "Hello World" application 
> from the base WPF Template in VS2010 with IronPython Tools:
>
> Exception: IronPython.Runtime.Exceptions.ImportException: No module 
> named wpf
>
> I guess the search paths for modules need modifying, but im not sure 
> how to do that.
>
> Seems a bit weird as i would expect basic template code to run without 
> tweaking, so maybe i messed something up with the install.
>
> Any suggestions welcome.
>
> Thanks
>
>
> _______________________________________________
> Users mailing list
> Users at lists.ironpython.com
> http://lists.ironpython.com/listinfo.cgi/users-ironpython.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ironpython.com/pipermail/users-ironpython.com/attachments/20110402/577d4533/attachment.htm>


More information about the Users mailing list