[IronPython] Building IronPython/IronRuby for Mono?

Markus Schaber m.schaber at 3s-software.com
Tue Mar 22 07:14:06 PDT 2011


Doug Blank wrote:

> > IronPython 2.7 and newer seem to need at least .NET 4.0, which needs
> > at least Mono 2.8.
> 
> Is that you need Mono 2.8 to build IronPython, or to run it?
> IronPython2.6 beta 2 is running fine under Mono 2.6.7.

As far as I can see, you need .NET 4 / Mono 2.8 for both compiling and
running.

IronPython 2.6.2 is delivered in two versions, one for .NET 4 and the
other one for .NET 2 (but using some C# 3 language features).

The main difference seems to be in the DLR libraries used, parts of it
have been integrated into the core libraries in .NET 4, so they are not
compatible between versions.

Best regards

Markus Schaber


More information about the Users mailing list