[IronPython] Building IronPython/IronRuby for Mono?

Jeff Hardy jdhardy at gmail.com
Tue Mar 22 10:30:52 PDT 2011


On Tue, Mar 22, 2011 at 11:03 AM, Doug Blank <doug.blank at gmail.com> wrote:
> I'm not too concerned about ipy.exe itself, but about being about to
> use the dlls.
>
> I'm trying to verify that the IronPython 2.7 dlls absolutely need Mono
> 2.8 or later. If that is true, I'll have to stay with IronPython 2.6
> until the rest of the Linux distros catch up (or I make my own version
> of Mono to download). Perhaps Miguel or someone from SuSE can add more
> details to the dependencies for building and running IronPython 2.7?

IronPython 2.7 *should* build for .NET 2.0, although it's not the
default (I don't remember the name of the MSBuild configuration to do
so, though). However, I don't think that was consistently tested, so I
don't know if it works. I would consider it not working a bug, though.

We won't provide binaries for 2.7/.NET2, but we don't want to prevent
someone building their own either. 3.0, however, will drop support for
.NET 2 entirely.

- Jeff


More information about the Users mailing list